Reaction Commerce Forums

Your application has errors. Waiting for file change


#1

Hi,
I am a newbie to reaction platform. I am trying to build the reaction using reaction-cli and I am seeing the following log when I run the command “reaction” on my PC(Windows 10). Could anyone help me please?:

Setting up plugin imports...

Setting up style imports...

Provisioning assets...

[[[[[ ~\G\reaction\test\reaction ]]]]]

=> Started proxy.
app/client/plugins.less: warn: There are some @import rules those are not taking effect as they are required to be in the beginning of the file.
app/client/plugins.less: warn: There are some @import rules those are not taking effect as they are required to be in the beginning of the file.
=> Errors prevented startup:

   While building for web.browser:
   imports/plugins/core/graphql/lib/mutations/updateFulfillmentOptionsForGroup.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/createFlatRateFulfillmentMethod.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/updateFlatRateFulfillmentMethod.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/deleteFlatRateFulfillmentMethod.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/enablePaymentMethodForShop.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/placeOrderWithExampleIOUPayment.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/placeOrderWithStripeCardPayment.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/queries/availablePaymentMethods.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/queries/paymentMethods.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/marketplace/client/util/placeMarketplaceOrderWithStripeCardPayment.graphql:1:41: Unterminated string constant (1:41)

   While building for web.browser.legacy:
   imports/plugins/core/graphql/lib/mutations/updateFulfillmentOptionsForGroup.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/createFlatRateFulfillmentMethod.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/updateFlatRateFulfillmentMethod.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/deleteFlatRateFulfillmentMethod.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/enablePaymentMethodForShop.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/placeOrderWithExampleIOUPayment.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/mutations/placeOrderWithStripeCardPayment.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/queries/availablePaymentMethods.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/graphql/lib/queries/paymentMethods.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/marketplace/client/util/placeMarketplaceOrderWithStripeCardPayment.graphql:1:41: Unterminated string constant (1:41)

   While building for os.windows.x86_64:
   imports/plugins/core/core/server/no-meteor/schemas/address.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/base.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/currency.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/email.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/metafield.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/node.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/shop.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/core/server/no-meteor/schemas/tag.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/accounts/server/no-meteor/schemas/account.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/accounts/server/no-meteor/schemas/group.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/accounts/server/no-meteor/schemas/role.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/cart/server/no-meteor/schemas/cart.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/cart/server/no-meteor/schemas/checkout.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/catalog/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/orders/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/payments/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/product/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/core/shipping/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/marketplace/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/payments-example/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/payments-stripe/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/shipping-rates/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)
   imports/plugins/included/sitemap-generator/server/no-meteor/schemas/schema.graphql:1:41: Unterminated string constant (1:41)

=> Your application has errors. Waiting for file change.
Error starting Mongo (2 tries left): New replica set configuration version must be greater than old, but 55842 is not greater than 127709 for replica set meteor
=> Started MongoDB.

FYI, the reaction-v outputs this:
Node: 8.12.0
NPM: 6.4.1
Meteor Node: 8.11.4
Meteor NPM: 6.4.1
Reaction CLI: 0.29.0
Reaction: 2.0.0-rc.6
Reaction branch: master
Docker: 18.03.0-ce

Your help is very much appreciated