Reaction test issue


#1

Hi,
I installed reaction and initialized it using, it works. I have a problem in running the test. I tried to run reaction test
I didn’t change any thing in the code, but the integration tests fail.
This is the log:

0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘run’, ‘test:integration’ ]
2 info using npm@5.6.0
3 info using node@v9.11.1
4 verbose run-script [ ‘pretest:integration’,
4 verbose run-script ‘test:integration’,
4 verbose run-script ‘posttest:integration’ ]
5 info lifecycle reaction@1.14.1~pretest:integration: reaction@1.14.1
6 info lifecycle reaction@1.14.1~test:integration: reaction@1.14.1
7 verbose lifecycle reaction@1.14.1~test:integration: unsafe-perm in lifecycle true
8 verbose lifecycle reaction@1.14.1~test:integration: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/nada/reaction/node_modules/.bin:/usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/nada/reaction/node_modules/.bin:/home/nada/bin:/home/nada/.local/bin:/home/nada/bin:/home/nada/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/nada/.rvm/bin:/snap/bin:/home/nada/.rvm/bin:/home/nada/.rvm/bin
9 verbose lifecycle reaction@1.14.1~test:integration: CWD: /home/nada/reaction
10 silly lifecycle reaction@1.14.1~test:integration: Args: [ ‘-c’,
10 silly lifecycle ‘NODE_ENV=jesttest BABEL_DISABLE_CACHE=1 jest --no-cache /tests/’ ]
11 silly lifecycle reaction@1.14.1~test:integration: Returned: code: 1 signal: null
12 info lifecycle reaction@1.14.1~test:integration: Failed to exec test:integration script
13 verbose stack Error: reaction@1.14.1 test:integration: NODE_ENV=jesttest BABEL_DISABLE_CACHE=1 jest --no-cache /tests/
13 verbose stack Exit status 1
13 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:285:16)
13 verbose stack at EventEmitter.emit (events.js:180:13)
13 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:180:13)
13 verbose stack at maybeClose (internal/child_process.js:936:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)
14 verbose pkgid reaction@1.14.1
15 verbose cwd /home/nada/reaction
16 verbose Linux 4.4.0-133-generic
17 verbose argv “/usr/bin/node” “/usr/bin/npm” “run” “test:integration”
18 verbose node v9.11.1
19 verbose npm v5.6.0
20 error code ELIFECYCLE
21 error errno 1
22 error reaction@1.14.1 test:integration: NODE_ENV=jesttest BABEL_DISABLE_CACHE=1 jest --no-cache /tests/
22 error Exit status 1
23 error Failed at the reaction@1.14.1 test:integration script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]

Any suggestion?

Thanks