Reaction performance issue


#1

Hi,

I just installed reaction commerce on my mac (macOS Sierra with 8Gb). I realized that every time I start the app, the fan of my computer goes crazy and the node process takes more than 140% of CPU.

Is that normal ?

Node version : v7.5.0
Reaction version : 1.3.0


#2

Reaction 1.3.0 updated to Meteor 1.5 -> and we’ve also noticed the increased CPU usage. Not sure if it’s Meteor related or more related to the implementation of React through most of the UI now. However, we’re working on a loader for the React components and also adding dynamic loading of modules which should significantly improve performance over the next couple of release.


#3

Thanks Aaron for your answer. I’ve just used Meteor 1.5 to develop a smaller App and didn’t have any performance issues. I hope you’ll fix this very soon. Thanks again.


#4

hello, I’m using docker reactioncommerce version and need improve the general performance, here the docker-compose.yml file and an audit capture perfomance…

version: "3"

networks:
  comp_proxy:
    external: true
  internal:
    external: false

services:
  reactioncommerce.dev:
    container_name: reactioncommerce.dev
    restart: always
    image: reactioncommerce/reaction:v1.5.5
    environment:
      ROOT_URL: "https://reactioncommerce.dev"
      MONGO_URL: "mongodb://mongo:27017/reaction"
      VIRTUAL_HOST: "www.reactioncommerce.dev,reactioncommerce.dev"
      REACTION_EMAIL: "hello@reactioncommerce.dev"
      REACTION_USER: "admin"
      REACTION_AUTH: "test-dev"
    labels:
      - "traefik.backend=reactioncommerce.dev"
      - "traefik.frontend.rule=Host:reactioncommerce.dev"
      - "traefik.docker.network=comp_proxy"
      - "traefik.port=3000"
    networks:
      - internal
      - comp_proxy
    links:
      - db.reactioncommerce.dev:mongo
    depends_on:
      - db.reactioncommerce.dev

  db.reactioncommerce.dev:
    container_name: db.reactioncommerce.dev
    restart: always
    image: mongo:latest
    command: mongod --storageEngine=wiredTiger
    volumes:
      - ../live/db:/data/db
    labels:
      - "traefik.enable=false"
    networks:
      - internal


#5

Keep in mind that when Lighthouse audits the page, it throttles the CPU and network connection to emulate a nexus 5x device. So your perf numbers will be worse than loading the page directly in the browser.

See https://github.com/GoogleChrome/lighthouse/issues/2864 for more information on how to disable throttling in case you’re interested in desktop performance.