Reaction Commerce Forums

Reaction Container exits with Error


#1

Im am trying to get the reaction-platform v2.0.0-rc.9 running but it quits right after a few seconds. The installation seemed to finish successfully.

Inspecting the logs (docker-compose logs -f) the reaction-next-starterkit container shows only this:

Attaching to reactionnextstarterkit_web_1': No such file or directory'sh
reactionnextstarterkit_web_1 exited with code 127

The reaction container log shows this:

reaction_1  | npm WARN apollo-cache-inmemory@1.2.5 requires a peer of graphql@0.11.7 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-client@2.3.5 requires a peer of graphql@^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-link@1.2.2 requires a peer of graphql@^0.11.3 || ^0.12.3 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-link-http@1.5.4 requires a peer of graphql@^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-link-http-common@0.2.4 requires a peer of graphql@^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN graphql-iso-date@3.5.0 requires a peer of graphql@^0.5.0 || ^0.6.0 || ^0.7.0 || ^0.8.0-b || ^0.9.0 || ^0.10.0 || ^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN graphql-relay@0.5.5 requires a peer of graphql@^0.5.0 || ^0.6.0 || ^0.7.0 || ^0.8.0-b || ^0.9.0 || ^0.10.0 || ^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN graphql-tag@2.9.2 requires a peer of graphql@^0.9.0 || ^0.10.0 || ^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN react-addons-test-utils@15.6.2 requires a peer of react-dom@^15.4.2 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN react-taco-table@0.5.1 requires a peer of react@^15.3 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN react-taco-table@0.5.1 requires a peer of react-dom@^15.3 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
reaction_1  | npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
reaction_1  |
reaction_1  | up to date in 73.354s
reaction_1  | MongoDB replica set initialized and ready.
reaction_1  | Setting up plugin imports...
reaction_1  |
reaction_1  | Setting up style imports...
reaction_1  |
reaction_1  | Provisioning assets...
reaction_1  |
reaction_1  | [[[[[ /opt/reaction/src ]]]]]
reaction_1  |
reaction_1  | => Started proxy.
reaction_1  | => A patch (Meteor 1.8.0.2) for your current release is available!
reaction_1  |    Update this project now with 'meteor update --patch'.
reaction_1  | app/client/plugins.less: warn: There are some @import rules those are not taking effect as they are required to be in the beginning of the file.
reaction_1  |
reaction_1  | <--- Last few GCs --->
reaction_1  |
reaction_1  | [59:0x255d810]  2302651 ms: Scavenge 632.5 (1360.2) -> 629.7 (1360.2) MB, 45.4 / 1.9 ms  allocation failure
reaction_1  | [59:0x255d810]  2309316 ms: Scavenge 632.9 (1360.2) -> 630.0 (1360.2) MB, 5295.5 / 4.8 ms  allocation failure
reaction_1  | [59:0x255d810]  2319934 ms: Scavenge 633.7 (1360.2) -> 630.8 (1353.7) MB, 87.3 / 1.4 ms  allocation failure
reaction_1  | [59:0x255d810]  2323028 ms: Scavenge 631.5 (1353.7) -> 630.8 (1353.2) MB, 2247.1 / 17.9 ms  allocation failure
reaction_1  |
reaction_1  |
reaction_1  | <--- JS stacktrace --->
reaction_1  |
reaction_1  | ==== JS stack trace =========================================
reaction_1  |
reaction_1  | Security context: 0x7b28fea5879 <JSObject>
reaction_1  |     1: /* anonymous */ [fs.js:948] [bytecode=0xff6d93e42d9 offset=60](this=0x1aa609d2c801 <Object deprecated-map = 0xbf2968749>,path=0x340ea22ff459 <String[45]: /opt/reaction/src/meteor/templating/index.es6>)
reaction_1  |     2: statSync [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/no...
reaction_1  |
reaction_1  | FATAL ERROR: Committing semi space failed. Allocation failed - process out of memory
reaction_1  |  1: node::Abort() [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  2: 0x8c21ec [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  3: v8::Utils::ReportOOMFailure(char const*, bool) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  4: v8::internal::V8::FatalProcessOutOfMemory(char const*, bool) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  5: v8::internal::Heap::PerformGarbageCollection(v8::internal::GarbageCollector, v8::GCCallbackFlags) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  6: v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  7: v8::internal::Factory::CopyFixedArrayAndGrow(v8::internal::Handle<v8::internal::FixedArray>, int, v8::internal::PretenureFlag) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  8: v8::internal::FrameArray::AppendJSFrame(v8::internal::Handle<v8::internal::FrameArray>, v8::internal::Handle<v8::internal::Object>, v8::internal::Handle<v8::internal::JSFunction>, v8::internal::Handle<v8::internal::AbstractCode>, int, int) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/de
v_bundle/bin/node]
reaction_1  |  9: v8::internal::Isolate::CaptureSimpleStackTrace(v8::internal::Handle<v8::internal::JSReceiver>, v8::internal::FrameSkipMode, v8::internal::Handle<v8::internal::Object>) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 10: v8::internal::Isolate::CaptureAndSetSimpleStackTrace(v8::internal::Handle<v8::internal::JSReceiver>, v8::internal::FrameSkipMode, v8::internal::Handle<v8::internal::Object>) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 11: v8::internal::ErrorUtils::Construct(v8::internal::Isolate*, v8::internal::Handle<v8::internal::JSFunction>, v8::internal::Handle<v8::internal::Object>, v8::internal::Handle<v8::internal::Object>, v8::internal::FrameSkipMode, v8::internal::Handle<v8::internal::Object>, bool) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legac
y+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 12: v8::internal::Factory::NewError(v8::internal::Handle<v8::internal::JSFunction>, v8::internal::Handle<v8::internal::String>) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 13: v8::Exception::Error(v8::Local<v8::String>) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 14: node::UVException(v8::Isolate*, int, char const*, char const*, char const*, char const*) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 15: 0x902a85 [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 16: v8::internal::FunctionCallbackArguments::Call(void (*)(v8::FunctionCallbackInfo<v8::Value> const&)) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 17: 0xad712c [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 18: v8::internal::Builtin_HandleApiCall(int, v8::internal::Object**, v8::internal::Isolate*) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 19: 0x225d7d1042fd
reaction_1  | Aborted
reaction_1  | { Error: Command failed: meteor --raw-logs
reaction_1  |     at checkExecSyncError (child_process.js:601:13)
reaction_1  |     at execSync (child_process.js:641:13)
reaction_1  |     at _callee$ (/usr/local/lib/node_modules/reaction-cli/dist/commands/run.js:72:43)
reaction_1  |     at tryCatch (/usr/local/lib/node_modules/reaction-cli/node_modules/regenerator-runtime/runtime.js:65:40)
reaction_1  |     at Generator.invoke [as _invoke] (/usr/local/lib/node_modules/reaction-cli/node_modules/regenerator-runtime/runtime.js:303:22)
reaction_1  |     at Generator.prototype.(anonymous function) [as next] (/usr/local/lib/node_modules/reaction-cli/node_modules/regenerator-runtime/runtime.js:117:21)
reaction_1  |     at step (/usr/local/lib/node_modules/reaction-cli/dist/commands/run.js:98:191)
reaction_1  |     at /usr/local/lib/node_modules/reaction-cli/dist/commands/run.js:98:361
reaction_1  |     at <anonymous>
reaction_1  |     at process._tickCallback (internal/process/next_tick.js:188:7)
reaction_1  |   error: null,
reaction_1  |   cmd: 'meteor --raw-logs',
reaction_1  |   file: '/bin/sh',
reaction_1  |   args: [ '/bin/sh', '-c', 'meteor --raw-logs' ],
reaction_1  |   options:
reaction_1  |    { stdio: [ [Object], [Object], [Object] ],
reaction_1  |      shell: true,
reaction_1  |      file: '/bin/sh',
reaction_1  |      args: [ '/bin/sh', '-c', 'meteor --raw-logs' ],
reaction_1  |      envPairs:
reaction_1  |       [ 'TOOL_NODE_FLAGS=',
reaction_1  |         'NODE_VERSION=8.11.4',
reaction_1  |         'HOSTNAME=7d3b53e4f975',
reaction_1  |         'METEOR_WATCH_POLLING_INTERVAL_MS=10000',
reaction_1  |         'METEOR_VERSION=1.8',
reaction_1  |         'METEOR_DISABLE_OPTIMISTIC_CACHING=1',
reaction_1  |         'REACTION_EMAIL=admin@localhost',
reaction_1  |         'PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin',
reaction_1  |         'PWD=/opt/reaction/src',
reaction_1  |         'MONGO_URL=mongodb://mongo:27017/reaction',
reaction_1  |         'REACTION_USER=Admin',
reaction_1  |         'APP_BUNDLE_DIR=/opt/reaction/dist',
reaction_1  |         'ROOT_URL=http://localhost:3000',
reaction_1  |         'HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token',
reaction_1  |         'SHLVL=1',
reaction_1  |         'HOME=/home/node',
reaction_1  |         'REACTION_AUTH=r3@cti0n',
reaction_1  |         'YARN_VERSION=1.6.0',
reaction_1  |         'OAUTH2_CLIENT_DOMAINS=http://localhost:4000',
reaction_1  |         'REACTION_DOCKER_BUILD=true',
reaction_1  |         'REACTION_USER_NAME=admin',
reaction_1  |         'REACTION_SECURE_DEFAULT_ADMIN=false',
reaction_1  |         'APP_SOURCE_DIR=/opt/reaction/src',
reaction_1  |         'HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect',
reaction_1  |         'MONGO_OPLOG_URL=mongodb://mongo:27017/local',
reaction_1  |         'HYDRA_ADMIN_URL=http://hydra:4445',
reaction_1  |         'IDENTITY_PROVIDER_MODE=all',
reaction_1  |         '_=/usr/local/bin/reaction' ],
reaction_1  |      killSignal: undefined },
reaction_1  |   envPairs:
reaction_1  |    [ 'TOOL_NODE_FLAGS=',
reaction_1  |      'NODE_VERSION=8.11.4',
reaction_1  |      'HOSTNAME=7d3b53e4f975',
reaction_1  |      'METEOR_WATCH_POLLING_INTERVAL_MS=10000',
reaction_1  |      'METEOR_VERSION=1.8',
reaction_1  |      'METEOR_DISABLE_OPTIMISTIC_CACHING=1',
reaction_1  |      'REACTION_EMAIL=admin@localhost',
reaction_1  |      'PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin',
reaction_1  |      'PWD=/opt/reaction/src',
reaction_1  |      'MONGO_URL=mongodb://mongo:27017/reaction',
reaction_1  |      'REACTION_USER=Admin',
reaction_1  |      'APP_BUNDLE_DIR=/opt/reaction/dist',
reaction_1  |      'ROOT_URL=http://localhost:3000',
reaction_1  |      'HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token',
reaction_1  |      'SHLVL=1',
reaction_1  |      'HOME=/home/node',
reaction_1  |      'REACTION_AUTH=r3@cti0n',
reaction_1  |      'YARN_VERSION=1.6.0',
reaction_1  |      'OAUTH2_CLIENT_DOMAINS=http://localhost:4000',
reaction_1  |      'REACTION_DOCKER_BUILD=true',
reaction_1  |      'REACTION_USER_NAME=admin',
reaction_1  |      'REACTION_SECURE_DEFAULT_ADMIN=false',
reaction_1  |      'APP_SOURCE_DIR=/opt/reaction/src',
reaction_1  |      'HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect',
reaction_1  |      'MONGO_OPLOG_URL=mongodb://mongo:27017/local',
reaction_1  |      'HYDRA_ADMIN_URL=http://hydra:4445',
reaction_1  |      'IDENTITY_PROVIDER_MODE=all',
reaction_1  |      '_=/usr/local/bin/reaction' ],
reaction_1  |   stderr: null,
reaction_1  |   stdout: null,
reaction_1  |   pid: 58,
reaction_1  |   output: [ null, null, null ],
reaction_1  |   signal: null,
reaction_1  |   status: 134 }
reaction_1  |
reaction_1  | Error: App failed to start
reaction_1  | npm WARN apollo-cache-inmemory@1.2.5 requires a peer of graphql@0.11.7 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-client@2.3.5 requires a peer of graphql@^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-link@1.2.2 requires a peer of graphql@^0.11.3 || ^0.12.3 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-link-http@1.5.4 requires a peer of graphql@^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN apollo-link-http-common@0.2.4 requires a peer of graphql@^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN graphql-iso-date@3.5.0 requires a peer of graphql@^0.5.0 || ^0.6.0 || ^0.7.0 || ^0.8.0-b || ^0.9.0 || ^0.10.0 || ^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN graphql-relay@0.5.5 requires a peer of graphql@^0.5.0 || ^0.6.0 || ^0.7.0 || ^0.8.0-b || ^0.9.0 || ^0.10.0 || ^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN graphql-tag@2.9.2 requires a peer of graphql@^0.9.0 || ^0.10.0 || ^0.11.0 || ^0.12.0 || ^0.13.0 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN react-addons-test-utils@15.6.2 requires a peer of react-dom@^15.4.2 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN react-taco-table@0.5.1 requires a peer of react@^15.3 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN react-taco-table@0.5.1 requires a peer of react-dom@^15.3 but none is installed. You must install peer dependencies yourself.
reaction_1  | npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
reaction_1  | npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
reaction_1  |
reaction_1  | up to date in 85.143s
reaction_1  | MongoDB replica set initialized and ready.
reaction_1  | Setting up plugin imports...
reaction_1  |
reaction_1  | Setting up style imports...
reaction_1  |
reaction_1  | Provisioning assets...
reaction_1  |
reaction_1  | [[[[[ /opt/reaction/src ]]]]]
reaction_1  |
reaction_1  | => Started proxy.
reaction_1  | => A patch (Meteor 1.8.0.2) for your current release is available!
reaction_1  |    Update this project now with 'meteor update --patch'.
reaction_1  | app/client/plugins.less: warn: There are some @import rules those are not taking effect as they are required to be in the beginning of the file.
reaction_1  | FATAL ERROR: NewSpace::Rebalance Allocation failed - process out of memory
reaction_1  |
reaction_1  | <--- Last few GCs --->
reaction_1  |
reaction_1  | [69:0x2d0f810]   473126 ms: Scavenge 1348.0 (1405.2) -> 1332.6 (1405.2) MB, 126.3 / 1.2 ms  allocation failure
reaction_1  | [69:0x2d0f810]   483228 ms: Scavenge 1348.1 (1405.2) -> 1332.7 (1405.2) MB, 9950.1 / 3.2 ms  allocation failure
reaction_1  | [69:0x2d0f810]   483407 ms: Scavenge 1348.1 (1405.2) -> 1332.7 (1405.2) MB, 131.6 / 1.5 ms  allocation failure
reaction_1  | [69:0x2d0f810]   483667 ms: Scavenge 1348.3 (1405.2) -> 1333.2 (1405.2) MB, 135.5 / 2.4 ms  allocation failure
reaction_1  |
reaction_1  |
reaction_1  | <--- JS stacktrace --->
reaction_1  | Cannot get stack trace in GC.
reaction_1  |  1: node::Abort() [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  2: 0x8c21ec [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  3: v8::Utils::ReportOOMFailure(char const*, bool) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  4: v8::internal::V8::FatalProcessOutOfMemory(char const*, bool) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  5: 0xa2f63b [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  6: v8::internal::MarkCompactCollector::Evacuate() [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  7: v8::internal::MarkCompactCollector::CollectGarbage() [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  8: v8::internal::Heap::MarkCompact() [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  |  9: v8::internal::Heap::PerformGarbageCollection(v8::internal::GarbageCollector, v8::GCCallbackFlags) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 10: v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 11: v8::internal::Factory::NewRawOneByteString(int, v8::internal::PretenureFlag) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 12: v8::internal::Factory::NewStringFromOneByte(v8::internal::Vector<unsigned char const>, v8::internal::PretenureFlag) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 13: v8::internal::Factory::NumberToString(v8::internal::Handle<v8::internal::Object>, bool) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 14: v8::internal::Runtime_NumberToString(int, v8::internal::Object**, v8::internal::Isolate*) [/home/node/.meteor/packages/meteor-tool/.1.8.0.1gdnmok.4nus++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node]
reaction_1  | 15: 0x281fd71842fd
reaction_1  | Aborted
reaction_1  | { Error: Command failed: meteor --raw-logs
reaction_1  |     at checkExecSyncError (child_process.js:601:13)
reaction_1  |     at execSync (child_process.js:641:13)
reaction_1  |     at _callee$ (/usr/local/lib/node_modules/reaction-cli/dist/commands/run.js:72:43)
reaction_1  |     at tryCatch (/usr/local/lib/node_modules/reaction-cli/node_modules/regenerator-runtime/runtime.js:65:40)
reaction_1  |     at Generator.invoke [as _invoke] (/usr/local/lib/node_modules/reaction-cli/node_modules/regenerator-runtime/runtime.js:303:22)
reaction_1  |     at Generator.prototype.(anonymous function) [as next] (/usr/local/lib/node_modules/reaction-cli/node_modules/regenerator-runtime/runtime.js:117:21)
reaction_1  |     at step (/usr/local/lib/node_modules/reaction-cli/dist/commands/run.js:98:191)
reaction_1  |     at /usr/local/lib/node_modules/reaction-cli/dist/commands/run.js:98:361
reaction_1  |     at <anonymous>
reaction_1  |     at process._tickCallback (internal/process/next_tick.js:188:7)
reaction_1  |   error: null,
reaction_1  |   cmd: 'meteor --raw-logs',
reaction_1  |   file: '/bin/sh',
reaction_1  |   args: [ '/bin/sh', '-c', 'meteor --raw-logs' ],
reaction_1  |   options:
reaction_1  |    { stdio: [ [Object], [Object], [Object] ],
reaction_1  |      shell: true,
reaction_1  |      file: '/bin/sh',
reaction_1  |      args: [ '/bin/sh', '-c', 'meteor --raw-logs' ],
reaction_1  |      envPairs:
reaction_1  |       [ 'TOOL_NODE_FLAGS=',
reaction_1  |         'NODE_VERSION=8.11.4',
reaction_1  |         'HOSTNAME=7d3b53e4f975',
reaction_1  |         'METEOR_WATCH_POLLING_INTERVAL_MS=10000',
reaction_1  |         'METEOR_VERSION=1.8',
reaction_1  |         'METEOR_DISABLE_OPTIMISTIC_CACHING=1',
reaction_1  |         'REACTION_EMAIL=admin@localhost',
reaction_1  |         'PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin',
reaction_1  |         'PWD=/opt/reaction/src',
reaction_1  |         'MONGO_URL=mongodb://mongo:27017/reaction',
reaction_1  |         'REACTION_USER=Admin',
reaction_1  |         'APP_BUNDLE_DIR=/opt/reaction/dist',
reaction_1  |         'ROOT_URL=http://localhost:3000',
reaction_1  |         'HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token',
reaction_1  |         'SHLVL=1',
reaction_1  |         'HOME=/home/node',
reaction_1  |         'REACTION_AUTH=r3@cti0n',
reaction_1  |         'YARN_VERSION=1.6.0',
reaction_1  |         'OAUTH2_CLIENT_DOMAINS=http://localhost:4000',
reaction_1  |         'REACTION_DOCKER_BUILD=true',
reaction_1  |         'REACTION_USER_NAME=admin',
reaction_1  |         'REACTION_SECURE_DEFAULT_ADMIN=false',
reaction_1  |         'APP_SOURCE_DIR=/opt/reaction/src',
reaction_1  |         'HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect',
reaction_1  |         'MONGO_OPLOG_URL=mongodb://mongo:27017/local',
reaction_1  |         'HYDRA_ADMIN_URL=http://hydra:4445',
reaction_1  |         'IDENTITY_PROVIDER_MODE=all',
reaction_1  |         '_=/usr/local/bin/reaction' ],
reaction_1  |      killSignal: undefined },
reaction_1  |   envPairs:
reaction_1  |    [ 'TOOL_NODE_FLAGS=',
reaction_1  |      'NODE_VERSION=8.11.4',
reaction_1  |      'HOSTNAME=7d3b53e4f975',
reaction_1  |      'METEOR_WATCH_POLLING_INTERVAL_MS=10000',
reaction_1  |      'METEOR_VERSION=1.8',
reaction_1  |      'METEOR_DISABLE_OPTIMISTIC_CACHING=1',
reaction_1  |      'REACTION_EMAIL=admin@localhost',
reaction_1  |      'PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin',
reaction_1  |      'PWD=/opt/reaction/src',
reaction_1  |      'MONGO_URL=mongodb://mongo:27017/reaction',
reaction_1  |      'REACTION_USER=Admin',
reaction_1  |      'APP_BUNDLE_DIR=/opt/reaction/dist',
reaction_1  |      'ROOT_URL=http://localhost:3000',
reaction_1  |      'HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token',
reaction_1  |      'SHLVL=1',
reaction_1  |      'HOME=/home/node',
reaction_1  |      'REACTION_AUTH=r3@cti0n',
reaction_1  |      'YARN_VERSION=1.6.0',
reaction_1  |      'OAUTH2_CLIENT_DOMAINS=http://localhost:4000',
reaction_1  |      'REACTION_DOCKER_BUILD=true',
reaction_1  |      'REACTION_USER_NAME=admin',
reaction_1  |      'REACTION_SECURE_DEFAULT_ADMIN=false',
reaction_1  |      'APP_SOURCE_DIR=/opt/reaction/src',
reaction_1  |      'HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect',
reaction_1  |      'MONGO_OPLOG_URL=mongodb://mongo:27017/local',
reaction_1  |      'HYDRA_ADMIN_URL=http://hydra:4445',
reaction_1  |      'IDENTITY_PROVIDER_MODE=all',
reaction_1  |      '_=/usr/local/bin/reaction' ],
reaction_1  |   stderr: null,
reaction_1  |   stdout: null,
reaction_1  |   pid: 68,
reaction_1  |   output: [ null, null, null ],
reaction_1  |   signal: null,
reaction_1  |   status: 134 }
reaction_1  |
reaction_1  | Error: App failed to start
reaction_reaction_1 exited with code 1

#2

@thopras Looks like you haven’t allocated enough RAM to Docker. If you’re still having this issue, can you go into your Docker settings and allocate a minimum of 6GB?


#3

Oh yes, thank you. This solved my problem.