Module in imports/plugins/custom not overriding default view


#1

Hi there,

I have been following the customization tutorial in the docs to create the beesknees shop demo. I have now tried on both fedora 24 linux and mac osx yosemite 10.10.5.

Each time I get a View like this

As you can see it does not seem to override the default view in reaction.

This has come from a fresh checkout of reaction and the files copied from https://github.com/reactioncommerce/reaction-example-plugin in the imports/plugins/custom directory.

In both MAC OSX and fedora linux I have the same error when trying to npm install :

" npm ERR! bcrypt@1.0.2 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bcrypt@1.0.2 install script ‘node-pre-gyp install --fallback-to-build’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the bcrypt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs bcrypt
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls bcrypt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /Users/andrewfinlayson/Documents/reaction/npm-debug.log

I am not sure if that is of any siginificance. Any suggestions here? Is there something I have missed? I could install a copy of ubuntu on my machine if its a fedora issue, I have been meaning to anyway for another project. "

All prerequisites have been met in both Fedora and MAC(although the version of XCode is 6.4 to be compatible with yosemite)

Any help is much appreciated :smile:

Andrew


#2

Hey,

You can see from your screenshot that it is in fact overriding the default layout (you can see where it says “BeesKneesLayout” in the navbar. What were you expecting to see that you aren’t seeing?


#3

The template itself,

Not just text.

E.g the footer with ‘about us’, the products from the JSON file. It just seems to be a thin static navbar with the text, not the actual view. I am sure I am meant to be seeing more than this?


#4

Have you replaced the existing Products.json with the one included in the repo?


#5

Sorry Im a little confused, I thought the “Custom plugins are always imported last so that they can override default settings.”, i.e. nothing outside of plugins should be touched for customization purposes?


#6

That applies to code, but not to fixtures. Data files are not loaded from anywhere except /private/data

https://docs.reactioncommerce.com/reaction-docs/master/plugin-fixtures-5


#7

Okay thanks for all your help Ill research a little further :smile:


#8

Look at the blue line between header and body:

Bee’s Knees layout layoutHeader template: layoutHeader layoutFooter template: Main Template: products

As you can see: “layoutHeader template” is “layoutHeader” which is consistent with “reaction-example-plugin/register.js”.

But “layoutFooter template” is empty and “Main Template” is “products” which are not consistent with “reaction-example-plugin/register.js”. “Main Template” is supposed to be “productsLanding”.
What is wrong here?


#9

Long time coming, but this plugin has been updated/fixed.