Failed to start reaction:"You're not in a Meteor Project directory"


#1

I’m on Win7.

After v0.14.0 released. I tried to run reaction with reaction-cli. But I kept receiving “You’re not in a Meteor Project directory”. Here’s the cmd result that I run reaction:

C:\Users\Robin\Documents\GitHub\reaction>reaction
Using settings file at settings/dev.settings.json
run: You're not in a Meteor project directory.

I’ve already reinstalled meteor(using meteor installer for windows) and reaction(reaction init). I also tried meteor create testapp. It looks completely fine after I run it. So I’m quite sure that there’s no problems with meteor.

Did I miss something or is there any further configurations I should do?
Thanks!


#2

reaction init clones Reaction from Github into the reaction directory. You need to cd reaction then reaction from inside that cloned directory. I’m not sure, but looking at your path, something looks strange, so maybe you aren’t really in the folder?

Also, we’ve just pushed an updated for the cli, to resolve some windows issue. If you can update… npm install -g reaction-cli and try again, that should help.


#3

I know when running reaction, I should be at the root directory of the app. I do cd reaction to get inside. List it out to make sure:

C:\Users\Robin\Documents\GitHub\reaction>dir
 磁碟區 C 中的磁碟是 ACER
 磁碟區序號:  82B3-7209

 C:\Users\Robin\Documents\GitHub\reaction 的目錄

2016/07/23  上午 11:46    <DIR>          .
2016/07/23  上午 11:46    <DIR>          ..
2016/07/22  下午 06:44               454 .codeclimate.yml
2016/07/22  下午 06:44               147 .dockerignore
2016/07/22  下午 06:44               313 .editorconfig
2016/07/22  下午 06:44                17 .eslintignore
2016/07/22  下午 06:44            10,243 .eslintrc
2016/07/22  下午 06:44    <DIR>          .github
2016/07/22  下午 06:44               475 .gitignore
2016/07/22  下午 06:44                 0 .gitmodules
2016/07/22  下午 06:44               563 .jsbeautifyrc
2016/07/22  下午 06:44    <DIR>          .meteor
2016/07/22  下午 06:44               370 .pullapprove.yml
2016/07/22  下午 06:44    <DIR>          .reaction
2016/07/22  下午 06:44             1,672 circle.yml
2016/07/22  下午 06:44    <DIR>          client
2016/07/22  下午 06:44    <DIR>          custom
2016/07/22  下午 06:44               316 docker-compose.yml
2016/07/22  下午 06:44                41 Dockerfile
2016/07/22  下午 06:44    <DIR>          imports
2016/07/22  下午 06:44    <DIR>          lib
2016/07/22  下午 06:44            35,773 LICENSE.md
2016/07/22  下午 06:44             2,396 package.json
2016/07/22  下午 06:44    <DIR>          private
2016/07/22  下午 06:44    <DIR>          public
2016/07/22  下午 06:44               354 reaction
2016/07/22  下午 06:44             4,306 README.md
2016/07/22  下午 06:44    <DIR>          server
2016/07/22  下午 06:44    <DIR>          settings

I tried reaciton again after updated reaction-cli like the way you’ve mentioned. But still got the same error message unfortunately. BTW, I didn’t use n for node version managing since it hasn’t supported yet. I use nvm for windows instead. Thinking of “maybe” there are some nodejs problems so I tried to reinstall node(v4.4.7, v6.3.1, no nvm, just nodejs), install reaction-cli then run reaction again, but nothing changes. It seems that there are some environmental issues on my pc.

Everything is fine when running the app on VM though. Just a bit upset about this prob.

Anyway, I really appreciate your reply. Thanks!


#4

Can you please run reaction -v from the project root and tell me what it says?


#5
C:\Users\Robin\Documents\GitHub\reaction>reaction -v
Reaction: 0.14.0
Reaction CLI: 0.3.9