Reaction Commerce Forums

Docker: EACCES: permission denied

#1

Hello,

Recently I’ve tried to run Reaction Commerce localy using docker-compose. Nevertheless I’m getting following error when I try to execute docker-compose up:

mongo_1 | 2019-03-21T18:48:52.585+0000 I NETWORK [listener] connection accepted from 172.28.0.3:41958 #1 (1 connection now open)
mongo_1 | 2019-03-21T18:48:52.592+0000 I NETWORK [conn1] received client metadata from 172.28.0.3:41958 conn: { driver: { name: “nodejs”, version: “3.1.13” }, os: { type: “Linux”, name: “linux”, architecture: “x64”, version: “4.15.0-36-generic” }, platform: “Node.js v8.11.4, LE, mongodb-core: 3.1.11” }
mongo_1 | 2019-03-21T18:48:52.604+0000 I REPL [conn1] replSetInitiate admin command received from client
reaction_1 | MongoDB replica set initialized and ready.
mongo_1 | 2019-03-21T18:48:52.609+0000 I NETWORK [conn1] end connection 172.28.0.3:41958 (0 connections now open)
reaction_1 | (node:52) ExperimentalWarning: The ESM module loader is experimental.
reaction_1 | Setting up plugin imports…
reaction_1 |
reaction_1 | Setting up plugin imports took 0s 8.913978ms
reaction_1 |
reaction_1 | Setting up style imports…
reaction_1 |
reaction_1 | Setting up style imports took 0s 6.978695ms
reaction_1 |
reaction_1 | Provisioning assets…
reaction_1 |
reaction_1 | Provisioning assets took 0s 8.839864ms
reaction_1 |
reaction_1 | Running command: meteor run --no-lint --no-release-check --raw-logs
reaction_1 | /home/node/.meteor/packages/meteor-tool/.1.8.0_2.1om3lwx.sy8++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/meteor-promise/promise_server.js:218
reaction_1 | throw error;
reaction_1 | ^
reaction_1 |
reaction_1 | Error: EACCES: permission denied, open ‘/opt/reaction/src/.meteor/local/.resolver-result-cache.json.1qhn8so.5r4rl’
reaction_1 | at Object.fs.openSync (fs.js:646:18)
reaction_1 | at Object.fs.writeFileSync (fs.js:1299:33)
reaction_1 | at Object.wrapper [as writeFile] (/tools/fs/files.js:1609:35)
reaction_1 | at Object.writeFileAtomically (/tools/fs/files.js:1071:11)
reaction_1 | at ProjectContext._saveResolverResultCache (/tools/project-context.js:619:11)
reaction_1 | at /tools/project-context.js:594:14
reaction_1 | at Object.enterJob (/tools/utils/buildmessage.js:388:12)
reaction_1 | at /tools/project-context.js:529:20
reaction_1 | at /tools/packaging/catalog/catalog.js:100:5
reaction_1 | at Object.capture (/tools/utils/buildmessage.js:283:5)
reaction_1 | at Object.catalog.runAndRetryWithRefreshIfHelpful (/tools/packaging/catalog/catalog.js:99:31)
reaction_1 | at ProjectContext.resolveConstraints (/tools/project-context.js:528:13)
reaction_1 | at /tools/project-context.js:300:9
reaction_1 | at Object.enterJob (/tools/utils/buildmessage.js:388:12)
reaction_1 | at ProjectContext.completeStagesThrough (/tools/project-context.js:290:18)
reaction_1 | at Profile.run (/tools/project-context.js:260:12)
reaction_1 | at Function.run (/tools/tool-env/profile.js:490:12)
reaction_1 | at ProjectContext.resolveConstraints (/tools/project-context.js:259:13)
reaction_1 | at /tools/runners/run-all.js:75:27
reaction_1 | at Object.capture (/tools/utils/buildmessage.js:283:5)
reaction_1 | at new Runner (/tools/runners/run-all.js:74:18)
reaction_1 | at Object.exports.run (/tools/runners/run-all.js:366:16)
reaction_1 | at Command.doRunCommand [as func] (/tools/cli/commands.js:417:17)
reaction_1 | at /tools/cli/main.js:1531:15
reaction_1 | { Error: Command failed: REACTION_METEOR_APP_COMMAND_START_TIME=1553194132779 meteor run --no-lint --no-release-check --raw-logs
reaction_1 | at checkExecSyncError (child_process.js:601:13)
reaction_1 | at Object.execSync (child_process.js:641:13)
reaction_1 | at run (file:///opt/reaction/src/.reaction/run/index.mjs:41:18)
reaction_1 | at file:///opt/reaction/src/.reaction/run/index.mjs:49:1
reaction_1 | at ModuleJob.run (internal/loader/ModuleJob.js:97:14)
reaction_1 | at
reaction_1 | error: null,
reaction_1 | cmd: 'REACTION_METEOR_APP_COMMAND_START_TIME=1553194132779 meteor run --no-lint --no-release-check --raw-logs ',
reaction_1 | file: ‘/bin/sh’,
reaction_1 | args:
reaction_1 | [ ‘/bin/sh’,
reaction_1 | ‘-c’,
reaction_1 | 'REACTION_METEOR_APP_COMMAND_START_TIME=1553194132779 meteor run --no-lint --no-release-check --raw-logs ’ ],
reaction_1 | options:
reaction_1 | { stdio: [ [Object], [Object], [Object] ],
reaction_1 | shell: true,
reaction_1 | file: ‘/bin/sh’,
reaction_1 | args:
reaction_1 | [ ‘/bin/sh’,
reaction_1 | ‘-c’,
reaction_1 | 'REACTION_METEOR_APP_COMMAND_START_TIME=1553194132779 meteor run --no-lint --no-release-check --raw-logs ’ ],
reaction_1 | envPairs:
reaction_1 | [ ‘TOOL_NODE_FLAGS=’,
reaction_1 | ‘NODE_VERSION=8.11.4’,
reaction_1 | ‘HOSTNAME=5bd32b7f73e7’,
reaction_1 | ‘METEOR_WATCH_POLLING_INTERVAL_MS=10000’,
reaction_1 | ‘METEOR_VERSION=1.8.0.2’,
reaction_1 | ‘METEOR_DISABLE_OPTIMISTIC_CACHING=1’,
reaction_1 | ‘REACTION_EMAIL=piotr.wilga@mobica.com’,
reaction_1 | ‘PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin’,
reaction_1 | ‘PWD=/opt/reaction/src’,
reaction_1 | ‘MONGO_URL=mongodb://mongo:27017/reaction’,
reaction_1 | ‘REACTION_USER=admin’,
reaction_1 | ‘APP_BUNDLE_DIR=/opt/reaction/dist’,
reaction_1 | ‘ROOT_URL=http://localhost:3000’,
reaction_1 | ‘HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token’,
reaction_1 | ‘SHLVL=1’,
reaction_1 | ‘HOME=/home/node’,
reaction_1 | ‘REACTION_AUTH=password’,
reaction_1 | ‘YARN_VERSION=1.6.0’,
reaction_1 | ‘OAUTH2_CLIENT_DOMAINS=http://localhost:4000’,
reaction_1 | ‘REACTION_DOCKER_BUILD=true’,
reaction_1 | ‘REACTION_USER_NAME=admin’,
reaction_1 | ‘REACTION_SECURE_DEFAULT_ADMIN=false’,
reaction_1 | ‘APP_SOURCE_DIR=/opt/reaction/src’,
reaction_1 | ‘HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect’,
reaction_1 | ‘MONGO_OPLOG_URL=mongodb://mongo:27017/local’,
reaction_1 | ‘HYDRA_ADMIN_URL=http://hydra:4445’,
reaction_1 | ‘IDENTITY_PROVIDER_MODE=all’,
reaction_1 | '
=/usr/local/bin/node’ ],
reaction_1 | killSignal: undefined },
reaction_1 | envPairs:
reaction_1 | [ ‘TOOL_NODE_FLAGS=’,
reaction_1 | ‘NODE_VERSION=8.11.4’,
reaction_1 | ‘HOSTNAME=5bd32b7f73e7’,
reaction_1 | ‘METEOR_WATCH_POLLING_INTERVAL_MS=10000’,
reaction_1 | ‘METEOR_VERSION=1.8.0.2’,
reaction_1 | ‘METEOR_DISABLE_OPTIMISTIC_CACHING=1’,
reaction_1 | ‘REACTION_EMAIL=piotr.wilga@mobica.com’,
reaction_1 | ‘PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin’,
reaction_1 | ‘PWD=/opt/reaction/src’,
reaction_1 | ‘MONGO_URL=mongodb://mongo:27017/reaction’,
reaction_1 | ‘REACTION_USER=admin’,
reaction_1 | ‘APP_BUNDLE_DIR=/opt/reaction/dist’,
reaction_1 | ‘ROOT_URL=http://localhost:3000’,
reaction_1 | ‘HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token’,
reaction_1 | ‘SHLVL=1’,
reaction_1 | ‘HOME=/home/node’,
reaction_1 | ‘REACTION_AUTH=password’,
reaction_1 | ‘YARN_VERSION=1.6.0’,
reaction_1 | ‘OAUTH2_CLIENT_DOMAINS=http://localhost:4000’,
reaction_1 | ‘REACTION_DOCKER_BUILD=true’,
reaction_1 | ‘REACTION_USER_NAME=admin’,
reaction_1 | ‘REACTION_SECURE_DEFAULT_ADMIN=false’,
reaction_1 | ‘APP_SOURCE_DIR=/opt/reaction/src’,
reaction_1 | ‘HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect’,
reaction_1 | ‘MONGO_OPLOG_URL=mongodb://mongo:27017/local’,
reaction_1 | ‘HYDRA_ADMIN_URL=http://hydra:4445’,
reaction_1 | ‘IDENTITY_PROVIDER_MODE=all’,
reaction_1 | '
=/usr/local/bin/node’ ],
reaction_1 | stderr: null,
reaction_1 | stdout: null,
reaction_1 | pid: 62,
reaction_1 | output: [ null, null, null ],
reaction_1 | signal: null,
reaction_1 | status: 1 }
reaction_1 |
reaction_1 | Error: App failed to start
reaction_reaction_1 exited with code 1

#2

I think this is being tracked here.