"create your plugin" bug


#1

I tried the “create your plugin” example downloaded from:
official plugin example

Then I ran:

reaction

When I browsed to localhost:3000

It shows a line between header and body:

Bee’s Knees layout layoutHeader template: layoutHeader layoutFooter template: Main Template: products

As you can see: “layoutHeader template” is “layoutHeader” which is consistent with “reaction-example-plugin/register.js”. But “layoutFooter template” is empty and “Main Template” is “products” which are not consistent with “reaction-example-plugin/register.js”. “Main Template” is supposed to be “productsLanding”.

For your convenience:

structure: {
template: “productsLanding”,
layoutHeader: “layoutHeader”,
layoutFooter: “layoutFooter”,
notFound: “productNotFound”,
dashboardHeader: “”,
dashboardControls: “dashboardControls”,
dashboardHeaderControls: “”,
adminControlsFooter: “adminControlsFooter”
} }

Is this a bug?

I used “Robomongo” to connect to local DB to check the collections “Packages” and “Templates”. But I could not find “beesknees” in “Packages” or “productsLanding” in “Templates”.
It looks something wrong here.

BTW, where is “this.Import” from in “reaction\server\api\core\core.js”
> this.Import.package(combinedSettings, shopId);

Thanks