Reaction Commerce Forums

Can access only storefront (Centos 7)

Hi all,
Sorry for this newbie question but I can’t figure out how it should be implemented.

I followed the guide from reaction docs how to run reaction on Dockers, and I’m running it on VPS with Centos 7 + Apache and I’m using DDNS domain name just for test purpose to not use IP instead of the name.
Due to link restrictions I can’t paste whole Apache config but for idea I’m using ProxyPass which looks like this for all dockers :

ProxyPass / http://127.0.0.1:4000/

Storefront seems works fine but when I click on sign or domain.name/admin it doesn’t forwards it to domain :frowning: instead I’m getting this :
http://localhost:4444/oauth2/auth?loginAction=signin&response_type=code&redirect_uri=http%3A%2F%2Flocalhost%3A4000%2Fcallback&scope=offline%20openid&state=nIDtsjewFRcy8VaEf7OUFRky&client_id=example-storefront

Is there any guide how to run it or what should I do? :frowning: I’m bit confused and totally new for Reaction platform.

Thank you so much.

Welcome to the Reaction community, @zimmer!

This is perfectly normal. You’re getting redirected to Hydra, which is an OAuth 2.0 server which manages session tokens. Then, this service will redirect you to Reaction Identity, an identity provider which takes care of the actual login/signup, and only then will you be redirected back to your admin or storefront.

@loanlaux Thank you for greeting.

Yeah, I understand that it’s normal behavior, but the problem is that I’m using VPS with Domain name, so when I’m trying to connect Hydra (OAuth2.0) instead to redirect it via domain name it redirects to localhost:4080. So basically my question is how to make it redirect with the domain name and not localhost as it can’t be accessed via public network obviously. I’ve tired to use proxy / localhost:4080 in Apache config on the server, but it didn’t work :frowning: any options how to run it properly?

I’m getting this error :
http://localhost:4444/oauth2/auth?loginAction=signin&response_type=code&redirect_uri=http%3A%2F%2Flocalhost%3A4000%2Fcallback&scope=offline%20openid&state=MDRCrHw0CxxcI49c2yS1YI1s&client_id=example-storefront

but I want this to redirect not localhost but domain.com/oauth2 … etc.

@zimmer Do all of your URL environment variables on all services mention your domain instead of localhost?

@loanlaux Actually, none of the variables in (env) are mentioned for my domain. I just followed the instructions and did the next steps :

  1. git clone git@github.com:reactioncommerce/reaction-development-platform.git
  2. cd reaction-development-platform
  3. make

All containers are running, and I suppose that network is configured for all dockers to communicate with each-other via bridge (reaction.localhost). I might be wrong as dockers are totally new for me.

Can you guide me where do I need to write those variables and what it should be? only domain name?

Thanks.