Reaction Commerce Forums

App Failed to Start in Mac

#1

I follow this documentation for setting up the reaction commerce

But when I did this command, it gives me an error
cd reaction
docker-compose logs -f

This is the error that I encountered:

reaction_1 | Killed
reaction_1 | { Error: Command failed: REACTION_METEOR_APP_COMMAND_START_TIME=1554117611245 meteor run --no-lint --no-release-check --raw-logs
reaction_1 | at checkExecSyncError (child_process.js:601:13)
reaction_1 | at Object.execSync (child_process.js:641:13)
reaction_1 | at run (file:///opt/reaction/src/.reaction/run/index.mjs:41:18)
reaction_1 | at file:///opt/reaction/src/.reaction/run/index.mjs:49:1
reaction_1 | at ModuleJob.run (internal/loader/ModuleJob.js:97:14)
reaction_1 | at
reaction_1 | error: null,
reaction_1 | cmd: 'REACTION_METEOR_APP_COMMAND_START_TIME=1554117611245 meteor run --no-lint --no-release-check --raw-logs ',
reaction_1 | file: ‘/bin/sh’,
reaction_1 | args:
reaction_1 | [ ‘/bin/sh’,
reaction_1 | ‘-c’,
reaction_1 | 'REACTION_METEOR_APP_COMMAND_START_TIME=1554117611245 meteor run --no-lint --no-release-check --raw-logs ’ ],
reaction_1 | options:
reaction_1 | { stdio: [ [Object], [Object], [Object] ],
reaction_1 | shell: true,
reaction_1 | file: ‘/bin/sh’,
reaction_1 | args:
reaction_1 | [ ‘/bin/sh’,
reaction_1 | ‘-c’,
reaction_1 | 'REACTION_METEOR_APP_COMMAND_START_TIME=1554117611245 meteor run --no-lint --no-release-check --raw-logs ’ ],
reaction_1 | envPairs:
reaction_1 | [ ‘TOOL_NODE_FLAGS=’,
reaction_1 | ‘NODE_VERSION=8.11.4’,
reaction_1 | ‘HOSTNAME=0934546182ae’,
reaction_1 | ‘METEOR_WATCH_POLLING_INTERVAL_MS=10000’,
reaction_1 | ‘METEOR_VERSION=1.8.0.2’,
reaction_1 | ‘METEOR_DISABLE_OPTIMISTIC_CACHING=1’,
reaction_1 | ‘REACTION_EMAIL=admin@localhost’,
reaction_1 | ‘PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin’,
reaction_1 | ‘PWD=/opt/reaction/src’,
reaction_1 | ‘MONGO_URL=mongodb://mongo:27017/reaction’,
reaction_1 | ‘REACTION_USER=Admin’,
reaction_1 | ‘APP_BUNDLE_DIR=/opt/reaction/dist’,
reaction_1 | ‘ROOT_URL=http://localhost:3000’,
reaction_1 | ‘HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token’,
reaction_1 | ‘SHLVL=1’,
reaction_1 | ‘HOME=/home/node’,
reaction_1 | ‘REACTION_AUTH=r3@cti0n’,
reaction_1 | ‘YARN_VERSION=1.6.0’,
reaction_1 | ‘OAUTH2_CLIENT_DOMAINS=http://localhost:4000’,
reaction_1 | ‘REACTION_DOCKER_BUILD=true’,
reaction_1 | ‘REACTION_USER_NAME=admin’,
reaction_1 | ‘REACTION_SECURE_DEFAULT_ADMIN=false’,
reaction_1 | ‘APP_SOURCE_DIR=/opt/reaction/src’,
reaction_1 | ‘HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect’,
reaction_1 | ‘MONGO_OPLOG_URL=mongodb://mongo:27017/local’,
reaction_1 | ‘HYDRA_ADMIN_URL=http://hydra:4445’,
reaction_1 | ‘IDENTITY_PROVIDER_MODE=all’,
reaction_1 | ‘=/usr/local/bin/node’ ],
reaction_1 | killSignal: undefined },
reaction_1 | envPairs:
reaction_1 | [ ‘TOOL_NODE_FLAGS=’,
reaction_1 | ‘NODE_VERSION=8.11.4’,
reaction_1 | ‘HOSTNAME=0934546182ae’,
reaction_1 | ‘METEOR_WATCH_POLLING_INTERVAL_MS=10000’,
reaction_1 | ‘METEOR_VERSION=1.8.0.2’,
reaction_1 | ‘METEOR_DISABLE_OPTIMISTIC_CACHING=1’,
reaction_1 | ‘REACTION_EMAIL=admin@localhost’,
reaction_1 | ‘PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/node/.meteor:/home/node/.meteor:/opt/reaction/src/node_modules/.bin’,
reaction_1 | ‘PWD=/opt/reaction/src’,
reaction_1 | ‘MONGO_URL=mongodb://mongo:27017/reaction’,
reaction_1 | ‘REACTION_USER=Admin’,
reaction_1 | ‘APP_BUNDLE_DIR=/opt/reaction/dist’,
reaction_1 | ‘ROOT_URL=http://localhost:3000’,
reaction_1 | ‘HYDRA_TOKEN_URL=http://hydra:4444/oauth2/token’,
reaction_1 | ‘SHLVL=1’,
reaction_1 | ‘HOME=/home/node’,
reaction_1 | ‘REACTION_AUTH=r3@cti0n’,
reaction_1 | ‘YARN_VERSION=1.6.0’,
reaction_1 | ‘OAUTH2_CLIENT_DOMAINS=http://localhost:4000’,
reaction_1 | ‘REACTION_DOCKER_BUILD=true’,
reaction_1 | ‘REACTION_USER_NAME=admin’,
reaction_1 | ‘REACTION_SECURE_DEFAULT_ADMIN=false’,
reaction_1 | ‘APP_SOURCE_DIR=/opt/reaction/src’,
reaction_1 | ‘HYDRA_OAUTH2_INTROSPECT_URL=http://hydra:4445/oauth2/introspect’,
reaction_1 | ‘MONGO_OPLOG_URL=mongodb://mongo:27017/local’,
reaction_1 | ‘HYDRA_ADMIN_URL=http://hydra:4445’,
reaction_1 | ‘IDENTITY_PROVIDER_MODE=all’,
reaction_1 | '
=/usr/local/bin/node’ ],
reaction_1 | stderr: null,
reaction_1 | stdout: null,
reaction_1 | pid: 58,
reaction_1 | output: [ null, null, null ],
reaction_1 | signal: null,
reaction_1 | status: 137 }
reaction_1 |
reaction_1 | Error: App failed to start
reaction_reaction_1 exited with code 1

Hope this explains my issue.

Thanks.

#2

I had the same issue. Managed to fix by fixing permissions from a random Github issue… will try to find.

Also was suggested to up the Docker memory and swap (put mine at 6 GB and 1.5 GB).

EDIT: Here’s the link with details to fix the permissions: https://github.com/reactioncommerce/reaction/issues/5037#issuecomment-473590874

1 Like
#3

Hi @simpleshadow, thank you for your response.

I also fixed the issue by following this reaction commerce troubleshooting documentation:

1 Like
#4

In my experience this has indicated that your container is running out of memory. Try increasing the memory limit in your docker settings.

1 Like